Le site me demande TOUJOURS de me connecter a Internet.

Concerne uniquement les sujets en rapport avec le site MonWindows ou l'application
Annette59
Amateur
Rang : Amateur
Annette59 - 27 fév 2018, 07:31
Bonjour.

Firefox. J'avais mis le site en favoris. Hors, comme vous pouvez le constater, le site me dit que je ne suis pas connectée a Internet.
Un site inaccessible totalement ou accidentellement c'est courant, mais un avis comme quoi il n'y a pas d'Internet, je n'ai jamais vu ça de ma vie.
Pour y accéder ou bien je tape dans Google le nom du site puis je clique sur le lien. Ou bien je pars de la réponse dans ma boite mail. Dans ce 2 cas ça fonctionne. Mais jamais avec les favoris.
J'avais 4 fois recréée les marque page, soit normalement soit en non classé en 1 click et j'ai toujours la mème réponse.
Ne pas être connectée est impossible. Internet en panne uniquement pour monwindows est impossible
Merci de me dire comment solutionner. Être obligée de passer par la recherche pour y accéder est un cas super exceptionnel !
Merci de votre attention.
Pièces jointes
mw.JPG

pro_info
Staff
Rang : Staff
pro_info - 27 fév 2018, 10:18
Salut, ton favoris doit être erroné, vérifie en faisant un clic droit dessus puis éditer, si l'url est bien https://monwindows.com

Annette59
Amateur
Rang : Amateur
Annette59 - 27 fév 2018, 11:14
Bonjour

Lorsque je tape http://monwindows.com Firefox rajoute automatiquement le www
Oui mais avec ou sans www ça fonctionne ( sauf avec un favori) . C'est normal. Le sous domaine www n'est pas indispensable.
La recherche Google par exemple me donne toujours le site avec www.
J'ai du me débrouiller autrement pour avoir un favori spécial sans www. Modifier dans la config browser.fixup.alternate.prefix
Comme ça fonctionne avec les 2 formes le site a donc une redirection permanente 301. Comme quasiment tous les sites web de l'univers.
Les incidents proviennent lors de la création des marque page. Jamais eu ça auparavant. Curieux.
Résolu bizarrement donc.
Bonne journée.

Arnaud
Staff
Rang : Staff
Arnaud - 01 mars 2018, 16:39
C'est vraiment bizarre comme souci ! D'autres ont le même problème avec Firefox ? Chez moi tout roule pourtant.

Annette59
Amateur
Rang : Amateur
Annette59 - 01 mars 2018, 17:30
Bonjour
Jamais vu ça. Et ça ne peut pas être une erreur de favoris. On ne peut pas se tromper en "Marquer cette page" puisqu'on n’écrit rien du tout. Aucune erreur possible. On "marque" c'est tout
Le site Monwindows n'a pas de www, ce qui est inhabituel mais ça n'a aucune importance en principe. Puisque tous les sites ont une redirection depuis leur serveur. .
En faisant une recherche le site apparait bien toujours avec www.
Firefox par configuration a l'installation rajoute TOUJOURS les www manquants. Il est impossible de décocher cette fonction dans les Menus. Il faut pour cela passer en false une ligne de about:config. Un utilisateur lambda ne va pas faire ça.
C'est la raison pour laquelle j'avais poste une capture d’écran.
l'URL était parfaitement écrite et le message de se connecter n'apparait jamais nulle part.
Lorsqu'on n'est pas connecte du tout on ne peut pas accéder a son FAI. Et on ne peut rien faire.
Ca doit avoir une explication pour le webmaster. Il choisit le domaine canonique mais l'autre moyen, donc non canonique, doit être accessible par la programmation du serveur.
Firefox devient de plus en plus chatouilleux question securité.

...../.......
Grâce à ces techniques, vous pouvez configurer votre serveur pour répondre correctement à l'ensemble des cas (www ou non). Il s'agit d'une bonne démarche, étant donné qu'il est impossible de prédire ce qu'un utilisateur tapera dans sa barre d'adresse. Il faut simplement déterminer votre domaine canonique pour ensuite effectuer la redirection vers ce dernier.

Vous voulez lire les réponses des autres membres ?

Bonne nouvelle, ce sujet contient 6 réponses et elles vous seront peut-être d'une grande aide !

Pour pouvoir les consulter, vous devrez être connecté au forum

Se connecter / S'enregistrer